20.12.04

Amule en Ubuntu

Bueno ya me he instalado la distribución Ubuntu, y como no ya surgen las primeras necesidades de programas como puede ser un p2p.
He optado a utilizar Amule por las buenas críticas que le da bastante gente asi que esto es lo que he hecho:

root@afterdark:/home/awoisoak # apt-get install amule
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
E: No se pudo encontrar el paquete amule

Vemos que no encuentra el paquete amule, quizá no se llamase así, asi que vamos a ver si lo encontramos con este otro comando:

root@afterdark:/home/awoisoak # apt-cache search amule

Aun así, sigue sin encontrarlo.Asi pues vamos a actualizar el archivo sources-list (
En el archivo /etc/apt/sources.list se encuentra la lista de repositorios que usa apt-get para descargar paquetes de la red.):


root@afterdark:/home/awoisoak # gedit /etc/apt/sources.list

Sustituiremos esta parte del archivo:

...
## Uncomment the following two lines to fetch updated software from the network
# deb http://archive.ubuntu.com/ubuntu warty main restricted
# deb-src http://archive.ubuntu.com/ubuntu warty main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://archive.ubuntu.com/ubuntu warty universe
# deb-src http://archive.ubuntu.com/ubuntu warty universe

# deb http://security.ubuntu.com/ubuntu warty-security main restricted
# deb-src http://security.ubuntu.com/ubuntu warty-security main restricted
...


Por esta otra:

## Uncomment the following two lines to fetch updated software from the network
deb http://archive.ubuntu.com/ubuntu/ warty main restricted
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ warty universe
deb-src http://archive.ubuntu.com/ubuntu/ warty universe

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted

deb http://archive.ubuntu.com/ubuntu/ warty multiverse
deb-src http://archive.ubuntu.com/ubuntu/ warty multiverse

deb ftp://ftp.nerim.net/debian-marillat/ stable main
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
deb ftp://ftp.nerim.net/debian-marillat/ testing main

Ahora con el sources.list modificado, updateamos al sistema para que coga los cambios:

root@afterdark:/home/awoisoak # apt-get update

Y ya porfin ejecutamos el comando:

root@afterdark:/home/awoisoak # apt-get install amule

Mediante apt podemos instalar muchos mas programas, un ejemplo, instalar el plug-in de flash para el navegador Mozilla.Como no sabemos el nombre exacto del paquete lo buscamos por la palabra flash que seguramente la contendrá:


root@afterdark:/home/awoisoak # apt-cache search flash
gstreamer0.8-swfdec - SWF (Macromedia Flash) decoder plugin for GStreamer
libswfdec0 - SWF (Macromedia Flash) decoder library
libswfdec-dev - SWF (Macromedia Flash) decoder library
adzapper - squid advertisement zapper
aget - Multithreaded HTTP Download Accelerator
avrp - Programmer for Atmel AVR microcontrollers
flashkard - flash card learning tool for KDE
flashplugin-nonfree - Macromedia Flash Player plugin installer
flashybrid - automates use of a flash disk as the root filesystem
ftdi-eeprom - Tool for reading/erasing/flashing FTDI USB chip eeproms
fujiplay - Interface for Fuji digital cameras
gstreamer-swfdec - SWF (Macromedia Flash) decoder plugin for GStreamer
ifp-line - command line tool to access iRiver iFP audio players
keduca - interactive form-based tests for KDE
kvoctrain - vocabulary trainer for KDE
libflash-dev - GPL Flash (SWF) Library
libflash0 - GPL Flash (SWF) library
libroxen-flash2 - Flash2 module for the Roxen Challenger web server
libtk-tablematrix-perl - Table/matrix widget extension to Perl/Tk
mathwar - A flash card game designed to teach maths
microcode.ctl - Intel IA32 CPU Microcode Utility
mtd-tools - Memory Technology Device Tools
newsflash - gets news with the newnews command from a server
openwince-jtag - allows programming jtag capable devices such as CPUs or FPGAs
osflash - Reflash the OS of a Palm Computing Device
ploticus - A script driven business graphics package
ratpoison - Simple window manager with no fat library dependencies.
swf-player - SWF (Macromedia Flash) player
vrflash - tool to flash kernels and romdisks to Agenda VR
xmms-jess - visualization plugin for XMMS using various 2D and 3D methods
flashplayer-mozilla - Macromedia Flash Player

Nos salen varios paquetes que podemos instalar, nos fijamos que justamente el último es el que no sinteresa en este momento, así pues nos lo descargamos e instalamos :

root@afterdark:/home/awoisoak # apt-get install flashplayer-mozilla

5 comentarios:

Anónimo dijo...

muy util, me ha servido para conocer mas acerca de synaptic. Gracias

AwOiSoAk dijo...

Gracias a ti que ya se que alguien me lee y todo :-)

Anónimo dijo...

Gracias por la ayuda, no encontraba el aMule y no pensé que hubiese que cambiar las resources(creía que no había en Ubuntu,pues siempre he usado otras distros).

PD:Otro que te lee ;D

katherine dijo...

ohh te pasaste mxas gracias hace poco entre al mundo de ubuntu y me han servido mxo estas ayudas

no se si me puedas ayudar con esto pero no pierdo nada con preguntar

instale el amule pero ahora no puedo conectarme a ningun servidor cuando intento conectarme me dice conexion fallida y no logro descargar musica

AwOiSoAk dijo...

Pues podría ser que el fichero server.met que usa el Amule (y el Emule tambien) no estuviese funcionando bien.

Prueba en la pestaña de conexión a cambiar la URL de donde se actualiza ese fichero.

Ahora mismo no tengo que URL estoy usando pero navegando me he encontrado está a ver si te sirve.

http://ocbmaurice.dyns.net/pl/slist.pl?download/server-best.met